DELL Vostro 1510 で ブルースクリーン 0x0000007B エラー

Windows 起動時に 0x0000007B エラーのブルースクリーンで停止してしまう症状の DELL Vostro 1510 が持ち込まれました。

過去にもこの 0x0000007B エラーでブルースクリーンというパターンが幾つかあったのですが、HDD の損傷(物理・論理ともに)が殆どだったような…。今回もそうかなぁ、と思いながら、Acronis True Image でバックアップを取ってから、HDD Regenerator でチェックしてみたのですが、エラー無し。

ならば、ということで手持ちの Windows XP の CD-ROM で回復コンソールを起動してみたところ、内蔵 HDD が認識されません。あれ?こういうパターン、前もあったよなぁ…と思って BIOS をチェックすると、あったあった、ありました…。【Advanced】 → 【SATA AHCI Controller Mode】 です。ここの設定値が 【AHCI】 になっているのを 【ATA】 にしてやればとりあえず HDD は認識したはず…認識しました。で、そのまま HDD から起動させると、ブルースクリーンとならず起動しました。原因は AHCI ドライバの更新で不具合が出たのかな、と推測したのですが…。

ちなみに、WWW で検索すると以下のような記述がありました。

エラーコード 0x0000007B は Windows が起動時にハードディスクへ正しくアクセスできない時に発生します。例えば異なるインターフェースのハードディスクに交換した時や、ハードディスクの動作モードが変更された時などがそれにあたります。よくある事例として、IDE 互換で使用していた SATA ハードディスクの動作モードを AHCI モードに変更した場合や、動作モードが UDMA5 のコンピュータに動作モード UDMA6 のハードディスクを接続した場合などがあります。

このまま ATA モードで動かしても良いかと思いますが、折角ですので AHCI モードに戻そうと思い、以下の情報を参考に作業してみたのですが…。

ネット上にある情報を調べてやってみると意外にも簡単すぎるぐらいに簡単でした。「Device Manager」下の「IDE ATA/ATAPI Controller」下に2つ「Intel(R) ICH9M・・・Serial ATA Storage Controller・・・」があるのですが、そのうちの一番上についてドライバの更新を選び、ドライバの入っているフォルダーから「互換性のない」 Intel ICH9M E M SATA AHCI用ドライバを選択して強引に変更した後、PC再起動、BIOS設定に入って、ATAからAHCIに変更したらあっさりと起動、変更できてしまいました(その際もう一度再起動をしなくてはならない)。気持ち何となく速くなった思い込むことにすれば、とてもラッキーな気がするってだけで、そもそも必要なことだったどうかわかりませんが。

DELL のサポートからドライバ “Intel Matrix Strage Manager – Notebooks” をダウンロードして解凍… なんかウィルスセキュリティゼロがドライバの iastor.sys を Riskware だとか言って削除しちゃうんですけど!ということで、これが原因?とか思いました。同ファイル名のマルウェアがあるそうなので、完全に誤認識だよなぁ…。

お客様には顛末をご説明して、ATA モードで利用していただくようにしました。セキュリティ対策ソフトの誤認識ってある程度は仕方ないと思うのですが怖いですね…。

追記: 2010年 03月 14日

ソースネクストから 「ウイルスセキュリティをお使いのお客様へ 重要なお知らせ」 という情報が公開されました。あちゃー、やっちゃったね、って感じです…。デルも大変だったご様子。→ デルサポートニュース 「Stopエラー 0x0000007B」に関するご注意

コメント

  1. shi より:

    はじめまして。
    「DELL Vostro 1510 で ブルースクリーン 0×0000007B エラー」
    これ、そのまんま4/10(土)の夜の私のコトです…
    ブルースクリーンになってからもバックアップを取ればよかったんですね。
    True Image で半年前のバックアップを復元してから、ウィルスセキュリティゼロの誤認識ではないかと思い始め、(何回復元してもiastorが削除されるし、Windows XP のCD-ROM を入れると、その中のiastor.sysまで削除しようとするし。)
    検索しているうちにこちらの記事にたどり着きました。
    夫もウィルスセキュリティゼロなのにちゃんと動いているので、どうして?と思っていましたが、機種によってファイルの場所とか違ったりとか、そういうことなんですよね、きっと。
    同機種の方が同じ症状で、犯人はウィルスセキュリティゼロだと確信がもてました。ありがとうございます。
    まぁ、マルウェアじゃないとわかって良かったんですが、半年分の家計簿が消えてショックです…

  2. digitalbox より:

    shi さん、こんにちは。はじめまして。旦那様はウィルスセキュリティゼロでも大丈夫とのことで、おっしゃるようにファイルの場所とか、はたまたバージョン相違の問題なのかもしれません。貴重な情報ありがとうございます。データを失うショックって大きいですよね…。転ばぬ先のバックアップ、というのは頭ではわかっているのですが、こまめに実行するのは難しいものだと思います。僕も早く自動バックアップの環境を作ってしまわないと、と思いました…。

  3. […] This post was mentioned on Twitter by 美少女 and 美少女, hse9212. hse9212 said: @katsu2000x 治りました!BIOSでACHIモードからATAモードに変更して、起動できました。こちらを参考に。http://bit.ly/cJNkpr […]

  4. たけろく より:

    職場の上司に修理を依頼され、数日検索していたところ、本日ここが引っかかり治りました。
    全く状況が分からない所だったので回復コンソールを使おうとしたところハードディスクが認識していないという状況になり、
    vostro1510 ハードディスクで検索してたどり着きました。

    すんなり解決。 ありがとうございました。
    いやはやwindowsアップデート、ウィルスソフトアップデートは時々致命的なことをしてくれますね(^^;

  5. digitalbox より:

    たけろく さん、こんばんは。お役に立てたようでよかったです。確かに、たま~にですが、ウィルス対策ソフトって「やっちゃってくれる」んですよねぇ…。今回の件は致命的な誤作動だったので、ソースネクストも大変だなぁ、って感じがします。ユーザーのほうがもっと大変だよ!ってのは言うまでもないんですが…。